Most likely causes: Changes on network or configuration, network/router issue.

Eftpos button no longer there?

Quick Fixes:

  • Check that the iPad and Eftpos are on same network. (iPad settings > Wi-Fi)
  • Ensure you are entering the IP address in this format eg.- 192.168.1.345 - remove any extra digits after the last number.
  • Do IP addresses on Eftpos terminal and posBoss Eftpos settings match?
  • Close and restart the posBoss app.
  • Reboot both iPad and Eftpos terminal (remove terminal battery and replace)
  • Have you swapped to a new Terminal? You may need to do a full Delete and Reinstall of posBoss to refresh the settings and allow you to set up again.

Advanced

Most eftpos issues that occur between posBoss and the Smartpay device are caused by underlying issues on the Network or Router.

Here’s some troubleshooting tips.

  1. Try restarting your router. Turn off the router for a full minute then restart it. Leave it for another couple of minutes. Please note: If you have Star printers, the IP address may have changed so you’ll need to get the IP and enter in again to the posBoss printer settings.
  2. Check the IP address on your Smartpay terminal. In the posBoss app, go to Settings > Eftpos and check that the IP address is the same. If not, enter the IP address again and fully close and restart Posboss. Test again.
  3. Have there been any recent changes on your network? You may need to contact your IT provider to assist.
  4. Contact the Smartpay Technical Helpdesk Support on 0800 476 278.
  5. Contact posBoss support and advise what you've tried.
Did this answer your question?