When posBoss started, you could use any old iPad to happily run our software, but technology progresses quickly, as do our offerings, and the older iPads don't have the processing power to run the latest Apple software, let alone powerful business apps.

And when they fail, they fail big, usually right in the middle of a busy service!

So what model iPad should you be using and what iOS version?

As of April 2021 you should be using, at the very minimum, an iPad that can run Apple's operating system - iOS 12 with posBoss. However, If you are purchasing a new iPad, we suggest you buy one that can at least run iOS 14. This will ensure you have a good few years of smooth running.

Please check out this article to see a list of iPads and what iOS they can run. The iOS version is bolded.

To check what model iPad you have and what iOS version you iPad is running head to Settings > General > About

Make sure you are on the latest version of iOS here in settings, and posBoss (update from the app store).

Did this answer your question?