Most likely cause: Issues on your router when posBoss and Tyro are trying to connect

Is the Eftpos button no longer there?

If so, check out this article:

Some Quick Fixes for eftpos connection errors:

  • Have you selected Tyro on the management site (Settings > posBoss Settings > Control). If not, select it and then sync menu on the posBoss iPad app.
  • Try disconnecting and reconnecting the Tyro integration. 
  • Check the iPad and Eftpos are on same network. Look in iPad settings > Wi-Fi and make sure the wi-fi you are connected to is correct.
  • Close and restart the posBoss app.
  • in the posBoss iPad app head to Settings > Eftpos and make sure your Tyro terminal credentials are entered correctly.
  • Reboot both iPad and Eftpos terminal
  • Have you swapped to a new Terminal recently? You may need to do a full Delete and Reinstall of posBoss to refresh the settings and allow you to set up again.
  • When possible, try restarting your router. Turn off the router for a full minute then restart it. Leave it for another couple of minutes and check your eftpos settings again. Please note: If you have Star printers, the IP address may have changed so you may need to Search for printers again to locate them - in the posBoss printer settings.

If issues are still continuing...

Most eftpos issues that occur between posBoss and the Tyro eftpos terminal are caused by underlying issues on the Network or Router. Rebooting the router may help in the short term but if intermittent connection issues persist, check out the following article:

Did this answer your question?